Hawkeye OpenLRSng and Naze32 – RF interference issue

Links:

Issues:

  • Baseflight tool won’t flash the firmware over USB when minimOSD is connected to the naze32 rx/tx pins –

    Status: STM32 – timed out, programming: FAILED
    Status: STM32 Communication failed, wrong response, expected: 121 received: 31

    Fix: just disconnect the minimOSD or whatever is connected to tx/rx, could be a GPS or a bluetooth.

  • Random signal twitching on the servo/motor outputs and the radio inputs page in the config tool. First thought was that the channels twitching is caused by the naze32 noise on 432MHz being too close to the Hawkeye RX, but a quick check with a scope showed that there’s absolutely no jerking on the naze32 PPM input no matter how close the RX is to the naze32. At the same time, the motors outputs start twitching really bad when the RX is placed next to the naze32.
    Turns out, the naze32 is getting swamped by the telemetry signals from the Hawkeye receiver. Switching the telemetry off fixed this issue completely. Another approach is to try and shield the naze32 board from the telemetry interference – not tested.
This entry was posted in Uncategorized and tagged , . Bookmark the permalink.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>